Page tree
Skip to end of metadata
Go to start of metadata


Summary

Unauthorized users were potentially able to execute code within the space directory.

Advisory Release Date

 

Product

Linchpin Theme*

Linchpin Intranet Suite

Linchpin Essentials

Affected Versions

Linchpin Theme 2.25.2 and all prior versions

Linchpin Intranet Suite 5.0.1 and all prior versions

Linchpin Essentials 2.0.1 and all prior versions

Fixed Versions

Linchpin Theme 2.25.3

Linchpin Intranet Suite 5.0.2

Linchpin Essentials 2.0.2

Problem

During an internal security audit, we discovered that an attacker could potentially store code as a logged in user. This code would be executed when a corrupted space is clicked on within the space directory (the space directory would have to be set to tile view).

Affected are the apps Linchpin Theme up to and including version 2.25.2, Linchpin Intranet Suite up to and including version 5.0.1 and Linchpin Essentials up to and including version 2.0.1.

Severity

The vulnerability is rated as 8.7 according to CVSS. The score is calculated as CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N.


Solution

For Linchpin Theme customers: Update to Linchpin Theme version 2.25.3 or later.

For Linchpin Suite customers: Update to Linchpin Suite 5.0.2 or later.

For Linchpin Essentials customers: Update to Linchpin Essentials 2.0.2 or later.


Should you be unable to update the Linchpin Intranet Suite to one of the listed versions, please reach out to our support team at https://seibert.biz/help.



This page was last edited on 09/01/2021.